summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 19:44:55 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:47 +0100
commit95563d628acdf81032556db66440b01b9fa933f1 (patch)
tree5c9481d60785cc1f59b7ccbe7daacc5019acee33 /gnu/packages/games.scm
parent4fe742381222ac975e6af091266ad741b06c6135 (diff)
downloadpatches-95563d628acdf81032556db66440b01b9fa933f1.tar
patches-95563d628acdf81032556db66440b01b9fa933f1.tar.gz
gnu: Add kjumpingcube.
* gnu/packages/games.scm (kjumpingcube): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4ced96510a..ded27c1f63 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9444,3 +9444,42 @@ squares, the player with the most squares wins.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
+(define-public kjumpingcube
+ (package
+ (name "kjumpingcube")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kjumpingcube-" version ".tar.xz"))
+ (sha256
+ (base32 "0d67zqkf2xffjkj671gl2n6nj6jajyn6rgqqj5i6gm500mqi9rm1"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Simple tactical game for number-crunchers")
+ (description "KJumpingcube is a simple tactical game for one or two
+players, played on a grid of numbered squares. Each turn, players compete for
+control of the board by capturing or adding to one square.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))