summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-12-04 02:46:44 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-15 22:54:58 +0100
commit4dbd704d5dcfdb753b3308102cfcbad1311dcb63 (patch)
tree0d0257f58740df6160f9ef5e181a1c33420c13a0 /gnu/packages/games.scm
parent6704e88d42b7c13e39975bd9c1790c079df57305 (diff)
downloadpatches-4dbd704d5dcfdb753b3308102cfcbad1311dcb63.tar
patches-4dbd704d5dcfdb753b3308102cfcbad1311dcb63.tar.gz
gnu: Add lolcat
* gnu/packages/games.scm (lolcat): New package. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ded27c1f63..c8d671bbdc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -502,6 +502,45 @@ cows can think too: all you have to do is run @command{cowthink}. If you're
tired of cows, a variety of other ASCII-art messengers are available.")
(license license:gpl3+)))
+(define-public lolcat
+ (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
+ (revision "0"))
+ (package
+ (name "lolcat")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaseg/lolcat.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;; no check target
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dest (string-append out "/bin")))
+ (mkdir-p dest)
+ (install-file "lolcat" dest)
+ (install-file "censor" dest)
+ #t))))))
+ (home-page "https://github.com/jaseg/lolcat")
+ (synopsis "Rainbow coloring effect for text console display")
+ (description "@command{lolcat} concatenates files and streams like
+regular @command{cat}, but it also adds terminal escape codes between
+characters and lines resulting in a rainbow effect.")
+ (license license:wtfpl2))))
+
(define-public freedoom
(package
(name "freedoom")