summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-03 13:50:25 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-03 14:07:04 +0300
commit26d52476a08a0a12d58cb8c924f4ea69dd232514 (patch)
tree58264cca4144c2dd72cdf0a69f6966a9c0b4b647 /gnu/packages/games.scm
parentc9e7acbf0ed58772331f9e35890d5852c8fb9157 (diff)
downloadpatches-26d52476a08a0a12d58cb8c924f4ea69dd232514.tar
patches-26d52476a08a0a12d58cb8c924f4ea69dd232514.tar.gz
gnu: tome4: Update to 1.6.5.
* gnu/packages/games.scm (tome4): Update to 1.6.5. [arguments]: Use invoke in install phase
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 79971d7611..066e2c8cf3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -37,7 +37,7 @@
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
@@ -5181,7 +5181,7 @@ Crowther & Woods, its original authors, in 1995. It has been known as
(define-public tome4
(package
(name "tome4")
- (version "1.6.4")
+ (version "1.6.5")
(synopsis "Single-player, RPG roguelike game set in the world of Eyal")
(source
(origin
@@ -5190,7 +5190,7 @@ Crowther & Woods, its original authors, in 1995. It has been known as
version ".tar.bz2"))
(sha256
(base32
- "1hrh79aqmvwwd7idlr3lzpdpc9dgm1k5p7w2462chcjvd8vhfhb7"))
+ "0ifi057idid8xq7af8ybs99b6939hyfif1ml1ihjpx02vinmd419"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -5249,11 +5249,11 @@ Crowther & Woods, its original authors, in 1995. It has been known as
(wrapper (string-append bin "/" ,name)))
;; icon
(mkdir-p pixmaps)
- (system* unzip "-j"
- (string-append
- "game/engines/te4-" ,version ".teae")
- (string-append
- "data/gfx/" icon) "-d" pixmaps)
+ (invoke unzip "-j"
+ (string-append
+ "game/engines/te4-" ,version ".teae")
+ (string-append
+ "data/gfx/" icon) "-d" pixmaps)
;; game executable
(install-file "t-engine" data)
(mkdir-p bin)