summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 23:23:53 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:45 +0100
commit4c5ef9baca9d53727d91dcb5e233c97e58bc3b27 (patch)
tree818fbc321785c048aec0da39efc9ae88bee69f31 /gnu/packages/games.scm
parent5a0fc6953a0235b9913fff9047f8be6e59314c98 (diff)
downloadpatches-4c5ef9baca9d53727d91dcb5e233c97e58bc3b27.tar
patches-4c5ef9baca9d53727d91dcb5e233c97e58bc3b27.tar.gz
gnu: Add kdiamond.
* gnu/packages/games.scm (kdiamond): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b7d2371e43..574b6929f2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8557,3 +8557,43 @@ packs are included, as well as an editor to create new levels.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kdiamond
+ (package
+ (name "kdiamond")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kdiamond-" version ".tar.xz"))
+ (sha256
+ (base32 "1v5yb9hb26lk277zhw8d37ks829yfqr5anzx1qhms44gca5kqhva"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion", kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("knotifications" ,knotifications)
+ ("knotifyconfig" ,knotifyconfig)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Three-in-a-row game")
+ (description "KDiamond is a three-in-a-row game like Bejeweled. It
+features unlimited fun with randomly generated games and five difficulty
+levels with varying number of diamond colors and board sizes.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))