summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 01:32:37 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:46 +0100
commit01e2f2eddbeb827f128a17b04d05477124699034 (patch)
treed7438e09a7bc485c96cc79e265a036a481ab1372 /gnu/packages/games.scm
parent90e594d3aa4c53bf433be3dc17af233ccf6a0069 (diff)
downloadpatches-01e2f2eddbeb827f128a17b04d05477124699034.tar
patches-01e2f2eddbeb827f128a17b04d05477124699034.tar.gz
gnu: Add lskat.
* gnu/packages/games.scm (lskat): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 671643148f..2242229f9a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9042,3 +9042,43 @@ game has unlimited undo, redo, save and reload capabilities.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public lskat
+ (package
+ (name "lskat")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/lskat-" version ".tar.xz"))
+ (sha256
+ (base32 "1qk5hd27zb42pbcxq5wyzz62nj5f0qdmgy54r9rnk92pzzzk94s9"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Lieutnant Skat card game")
+ (description "Lieutnant Skat (from German \"Offiziersskat\") is a fun and
+engaging card game for two players, where the second player is either live
+opponent, or a built in artificial intelligence.
+
+Lieutnant Skat is a simplified variant of the Skat card game for two players.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))