summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-27 00:12:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-27 00:12:15 +0100
commit18af6870370226b4d502d7372844e7f2aded5887 (patch)
tree749d93209bd0cb9710ccaae2207df670f37eaa36 /gnu/packages/games.scm
parent0ab8ad46322bea331ed5f5592843ba35e7f38b37 (diff)
parent3089b70d766bd9ec70e1464867130b7b864fbe17 (diff)
downloadpatches-18af6870370226b4d502d7372844e7f2aded5887.tar
patches-18af6870370226b4d502d7372844e7f2aded5887.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/packages/icu4c.scm gnu/packages/man.scm gnu/packages/python-xyz.scm guix/scripts/environment.scm guix/scripts/pack.scm guix/scripts/package.scm guix/scripts/pull.scm guix/store.scm
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm37
1 files changed, 35 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0e37675775..0fc50ed271 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
+;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2561,7 +2562,7 @@ Protocol).")
(define-public extremetuxracer
(package
(name "extremetuxracer")
- (version "0.7.5")
+ (version "0.8.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2569,7 +2570,7 @@ Protocol).")
version "/etr-" version ".tar.xz"))
(sha256
(base32
- "1ly63316c07i0gyqqmyzsyvygsvygn0fpk3bnbg25fi6li99rlsg"))))
+ "05ysaxvsgps9fxc421kdifsxmc1sn6n79cjaa0k0i3fs9qqrja2b"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -10300,3 +10301,35 @@ range with the objective to hit as many dummy targets as possible within
soldiers, jeeps and tanks. The gameplay is simple but it is not that easy to
get high scores.")
(license license:gpl2+)))
+
+(define-public 7kaa
+ (package
+ (name "7kaa")
+ (version "2.15.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/the3dfxdude/7kaa/"
+ "releases/download/v" version "/"
+ "7kaa-" version ".tar.xz"))
+ (sha256
+ (base32 "0blj47mcsfw1sn3465j6iham8m6ki07iggnq4q8nnaqnryx710jc"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("enet" ,enet)
+ ("openal" ,openal)
+ ("sdl2" ,sdl2)))
+ (home-page "https://7kfans.com/")
+ (synopsis "Seven Kingdoms Ancient Adversaries: real-time strategy game")
+ (description
+ "Seven Kingdoms, designed by Trevor Chan, brings a blend of Real-Time
+Strategy with the addition of trade, diplomacy, and espionage. The game
+enables players to compete against up to six other kingdoms allowing players
+to conquer opponents by defeating them in war (with troops or machines),
+capturing their buildings with spies, or offering opponents money for their
+kingdom.")
+ (license license:gpl2+)))