summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-31 17:56:33 -0400
committerKei Kebreau <kei@openmailbox.org>2017-05-31 20:45:43 -0400
commite99039b5da6dfbc49a2f8cf0fb523a8049fe5ef8 (patch)
treee84f4f7f57dcdd001d83a4303f8eccff4168d108 /gnu/packages/game-development.scm
parentb6726480e2bee87b9ebc1d696f8b36465cd4321e (diff)
downloadpatches-e99039b5da6dfbc49a2f8cf0fb523a8049fe5ef8.tar
patches-e99039b5da6dfbc49a2f8cf0fb523a8049fe5ef8.tar.gz
gnu: Add python-xsge.
* gnu/packages/game-development.scm (python-xsge, python2-xsge): New variables.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index b7bcdee94c..d7f9d2456c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -249,6 +249,47 @@ levels.")
`(("python2-pathlib" ,python2-pathlib)
,@(package-propagated-inputs python2-tmx))))))
+(define-public python-xsge
+ (package
+ (name "python-xsge")
+ (version "2017.04.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/xsge/xsge-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "04il5yx0py6kchxxw6ydbbx0wpiyjf9dgkwsdynirpkczlnid3am"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; xSGE's setup.py script does not support one of the Python build
+ ;; system's default flags, "--single-version-externally-managed".
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero?
+ (system* "python" "setup.py" "install"
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--root=/")))))
+ #:tests? #f)) ; no check target
+ (propagated-inputs
+ `(("python-sge-pygame" ,python-sge-pygame)
+ ("python-pygame" ,python-pygame)
+ ("python-six" ,python-six)
+ ("python-tmx" ,python-tmx)))
+ (home-page "http://xsge.nongnu.org")
+ (synopsis "Extensions for the SGE Game Engine")
+ (description
+ "xSGE is a collection of modules that make doing certain tasks with the SGE
+Game Engine easier. In addition to SGE's conveniences, the user has access to a
+GUI toolkit, lighting and physics frameworks and @code{Tiled} TMX format
+support.")
+ (license license:gpl3+)))
+
+(define-public python2-xsge
+ (package-with-python2 python-xsge))
+
(define-public tiled
(package
(name "tiled")