summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-27 02:01:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-27 16:49:59 +0100
commit7da5db8e45850a798258db092e0028b9ca52e351 (patch)
treea71f2447e0585281cc95aae33011a431b72946d7 /gnu/packages/game-development.scm
parent130acf72f78feaf008c148a22680e15725b9112a (diff)
downloadpatches-7da5db8e45850a798258db092e0028b9ca52e351.tar
patches-7da5db8e45850a798258db092e0028b9ca52e351.tar.gz
gnu: godot: Update to 3.0.1.
* gnu/packages/game-development.scm (godot): Update to 3.0.1. [arguments]: End phases with #t and remove redundant MKDIR-P.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5deb5a3d91..3025a68ec1 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Julian Graham <joolean@gmail.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -1064,7 +1064,7 @@ games.")
(define-public godot
(package
(name "godot")
- (version "3.0")
+ (version "3.0.1")
(source (origin
(method url-fetch)
(uri
@@ -1073,7 +1073,7 @@ games.")
(file-name (string-append name "-" version))
(sha256
(base32
- "1jhp269n1a7c663v2555444icbjwzscj4r8cq4rrrap7r7dr4hyc"))))
+ "0k8c12nzhl98i9il9s3awbwdamkrwxk0s47jr7n8a3z93rpszd2p"))))
(build-system scons-build-system)
(arguments
`(#:scons ,scons-python2
@@ -1116,16 +1116,16 @@ games.")
(if (file-exists? "godot.x11.tools.64")
(rename-file "godot.x11.tools.64" "godot")
(rename-file "godot.x11.tools.32" "godot"))
- (install-file "godot" bin)))))
+ (install-file "godot" bin))
+ #t)))
(add-after 'install 'install-godot-desktop
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(desktop (string-append out "/share/applications"))
(icon-dir (string-append out "/share/pixmaps")))
- (mkdir-p desktop)
- (mkdir-p icon-dir)
(rename-file "icon.png" "godot.png")
(install-file "godot.png" icon-dir)
+ (mkdir-p desktop)
(with-output-to-file
(string-append desktop "/godot.desktop")
(lambda _