aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-27 03:55:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-27 03:55:24 +0200
commit9df24909e252980c2393d2baaa617c30db8c9dd8 (patch)
treea32bd0d0b993f05a51bd8f49993be99c0770262d /gnu/packages/game-development.scm
parentae40e02cd68d4e0ab10690bd4e59c698df472857 (diff)
parentfdabfdbf8d5e179b2726ae69ff8aec48b0504788 (diff)
downloadpatches-9df24909e252980c2393d2baaa617c30db8c9dd8.tar
patches-9df24909e252980c2393d2baaa617c30db8c9dd8.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index da3a850fed..b7bcdee94c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -262,13 +262,22 @@ levels.")
(base32
"1kcj2blrlfpghjv0qigip2qcbxfx7vv9i8nr4997hkwhsh6i2pjp"))))
(build-system gnu-build-system)
- (inputs `(("qt" ,qt)
- ("zlib" ,zlib)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("qttools" ,qttools)))
(arguments
'(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "translations/translations.pro"
+ (("LRELEASE =.*")
+ (string-append "LRELEASE = "
+ (assoc-ref inputs "qttools")
+ "/bin/lrelease\n")))
(let ((out (assoc-ref outputs "out")))
(system* "qmake"
(string-append "PREFIX=" out))))))))