summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-15 11:38:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-04-28 16:55:39 +0200
commit5b8d2ace9377b5bbfa1095545b1e9fba1a2d16ac (patch)
tree84b36a60a75305da1be340f9ca6e690f38bb2813 /gnu/packages/game-development.scm
parent8311a844164c1637c731f33bca9331a90d79678d (diff)
downloadpatches-5b8d2ace9377b5bbfa1095545b1e9fba1a2d16ac.tar
patches-5b8d2ace9377b5bbfa1095545b1e9fba1a2d16ac.tar.gz
gnu: godot: Remove unused bundled libraries from the source.
While at it, also use system libvpx. * gnu/packages/game-development.scm (godot)[source](snippet): New field. [arguments]: Add "builtin_libvpx=no" to #:scons-flags. [inputs]: Add LIBVPX.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index edbc9c0ca5..f6c9eba8c2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1073,7 +1074,25 @@ games.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0k8c12nzhl98i9il9s3awbwdamkrwxk0s47jr7n8a3z93rpszd2p"))))
+ "0k8c12nzhl98i9il9s3awbwdamkrwxk0s47jr7n8a3z93rpszd2p"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Drop libraries that we take from Guix. Note that some
+ ;; of these may be modified; see "thirdparty/README.md".
+ (with-directory-excursion "thirdparty"
+ (for-each delete-file-recursively
+ '("freetype"
+ "libogg"
+ "libpng"
+ "libtheora"
+ "libvorbis"
+ "libvpx"
+ "libwebp"
+ "openssl"
+ "opus"
+ "zlib"))
+ #t)))))
(build-system scons-build-system)
(arguments
`(#:scons ,scons-python2
@@ -1091,6 +1110,7 @@ games.")
"builtin_libpng=no"
"builtin_libtheora=no"
"builtin_libvorbis=no"
+ "builtin_libvpx=no"
"builtin_libwebp=no"
"builtin_openssl=no"
"builtin_opus=no"
@@ -1146,6 +1166,7 @@ games.")
("glu" ,glu)
("libtheora" ,libtheora)
("libvorbis" ,libvorbis)
+ ("libvpx" ,libvpx)
("libwebp" ,libwebp)
("libx11" ,libx11)
("libxcursor" ,libxcursor)