summaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-03-05 12:14:43 -0500
committerMark H Weaver <mhw@netris.org>2015-03-05 12:16:44 -0500
commit87d79282941de06a9b0c464df87c8d0456c145ce (patch)
treebcb34d47c72e7eb4136751eb052852d161ca1454 /gnu/packages/ftp.scm
parentb3886e0c53d1f6110bedfe0f1dd536498f266a97 (diff)
downloadpatches-87d79282941de06a9b0c464df87c8d0456c145ce.tar
patches-87d79282941de06a9b0c464df87c8d0456c145ce.tar.gz
gnu: lftp: Don't save unknown SSH host fingerprints to known_hosts by default.
* gnu/packages/patches/lftp-dont-save-unknown-host-fingerprint.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/ftp.scm (lftp): Add patch.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index f002122bb6..22ea1af965 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,7 +40,10 @@
version ".tar.xz"))
(sha256
(base32
- "1grmp8zg7cjgjinz66mrh53whigkqzl90nlxj05hapnhk3ns3vni"))))
+ "1grmp8zg7cjgjinz66mrh53whigkqzl90nlxj05hapnhk3ns3vni"))
+ (patches
+ (list (search-patch
+ "lftp-dont-save-unknown-host-fingerprint.patch")))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))