summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-09-07 11:06:25 +0200
committerLudovic Courtès <ludo@gnu.org>2017-09-07 13:57:42 +0200
commitc2ffcc4425946725f843466680b89b9b0aa1f45e (patch)
treee654e3b0ecc413991c597c438d2eb5556b2227b7 /gnu/packages/freedesktop.scm
parent26ba09ba356fa7ce35ba0a337be5a30987a3c729 (diff)
downloadpatches-c2ffcc4425946725f843466680b89b9b0aa1f45e.tar
patches-c2ffcc4425946725f843466680b89b9b0aa1f45e.tar.gz
gnu: elogind: Add '-L' flag for libcap in libelogind.la.
This fix allows us to revert this series of commits: 1b97e9261 * gnu: gdm: Add missing input. de0c89f18 * gnu: colord: Add missing input. 7e38ba654 * gnu: accountsservice: Add missing input. 166bc1b25 * gnu: network-manager: Add missing input. daae20894 * gnu: modem-manager: Add missing input. 1f919459e * gnu: udisks: Add missing input. 744e9d074 * gnu: mutter: Add missing input. 0cce140dc * gnu: gnome-session: Add missing input. 77c2476ae * gnu: polkit: Add missing input. 124ac301c * gnu: weston: Add missing input. 472c2223c * gnu: kmscon: Add missing input. * gnu/packages/freedesktop.scm (elogind)[arguments]: Add 'add-libcap-to-search-path' phase. (weston)[inputs]: Remove LIBCAP. (udisks): Likewise. (accountsservice): Likewise. (modem-manager): Likewise. * gnu/packages/gnome.scm (colord): Likewise (gnome-session): Likewise. (mutter): Likewise. (network-manager): Likewise. (gdm): Likewise. * gnu/packages/polkit.scm (polkit): Likewise. * gnu/packages/terminals.scm (kmscon): Likewise.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 89dab53cbc..83374bce6e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -252,7 +252,17 @@ the freedesktop.org XDG Base Directory specification.")
(substitute* "src/login/org.freedesktop.login1.service"
(("^Exec=.*")
(string-append "Exec=" (assoc-ref %outputs "out")
- "/libexec/elogind/elogind\n"))))))))
+ "/libexec/elogind/elogind\n")))))
+ (add-after 'install 'add-libcap-to-search-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Add a missing '-L' for libcap in libelogind.la. See
+ ;; <https://lists.gnu.org/archive/html/guix-devel/2017-09/msg00084.html>.
+ (let ((libcap (assoc-ref inputs "libcap"))
+ (out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/lib/libelogind.la")
+ (("-lcap")
+ (string-append "-L" libcap "/lib -lcap")))
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -451,7 +461,6 @@ applications, X servers (rootless or fullscreen) or other display servers.")
`(("cairo" ,cairo-xcb)
("dbus" ,dbus)
("elogind" ,elogind)
- ("libcap" ,libcap)
("libinput" ,libinput-minimal)
("libunwind" ,libunwind)
("libxcursor" ,libxcursor)
@@ -583,7 +592,6 @@ Analysis and Reporting Technology) functionality.")
`(("acl" ,acl)
("libatasmart" ,libatasmart)
("libgudev" ,libgudev)
- ("libcap" ,libcap)
("polkit" ,polkit)
("util-linux" ,util-linux)))
(outputs '("out"
@@ -684,8 +692,7 @@ message bus.")
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("libcap" ,libcap)
- ("shadow" ,shadow)
+ `(("shadow" ,shadow)
("polkit" ,polkit)))
(home-page "http://www.freedesktop.org/wiki/Software/AccountsService/")
(synopsis "D-Bus interface for user account query and manipulation")
@@ -782,8 +789,7 @@ which speak the Qualcomm MSM Interface (QMI) protocol.")
(propagated-inputs
`(("glib" ,glib))) ; required by mm-glib.pc
(inputs
- `(("libcap" ,libcap)
- ("libgudev" ,libgudev)
+ `(("libgudev" ,libgudev)
("libmbim" ,libmbim)
("libqmi" ,libqmi)
("polkit" ,polkit)))