summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-10 21:53:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 14:43:59 +0100
commit1f2e06014890e7ac94558f0595f2b699711cdde2 (patch)
tree7cb0956d277bc97acbb6c4db1155d3f571e69639 /gnu/packages/freedesktop.scm
parent209393a0033ae6ad127b5fd3f124cf7bce5314f9 (diff)
downloadpatches-1f2e06014890e7ac94558f0595f2b699711cdde2.tar
patches-1f2e06014890e7ac94558f0595f2b699711cdde2.tar.gz
gnu: Add waylandpp.
* gnu/packages/freedesktop.scm (waylandpp): New public variable.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d90e75352e..4750450f68 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -36,6 +36,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
@@ -452,6 +453,33 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(home-page "https://wayland.freedesktop.org")
(license license:expat)))
+(define-public waylandpp
+ (package
+ (name "waylandpp")
+ (version "0.2.5")
+ (home-page "https://github.com/NilsBrause/waylandpp")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (sha256
+ (base32
+ "16h57hzd688664qcyznzhjp3hxipdkzgv46x82yhkww24av8b55n"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("mesa" ,mesa)
+ ("pugixml" ,pugixml)))
+ (propagated-inputs
+ `(;; In Requires of the .pc files.
+ ("wayland" ,wayland)))
+ (synopsis "Wayland C++ bindings")
+ (description
+ "This package provides C++ bindings for the Wayland display protocol.")
+ (license license:bsd-2)))
+
(define-public weston
(package
(name "weston")