summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 15:20:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 15:20:25 +0100
commit02d38bd3a2c964698ef08524d6313b726ce63846 (patch)
tree94a0e57b2e017ba80a9f7309aae241862ea2e81f /gnu/packages/freedesktop.scm
parent2b965485e2f3a8755efff58fc1abad75df3e37a0 (diff)
parent776248419fe521afe9c6dd4b2fac6fc4b8b18e9b (diff)
downloadpatches-02d38bd3a2c964698ef08524d6313b726ce63846.tar
patches-02d38bd3a2c964698ef08524d6313b726ce63846.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3130103eaf..7c497ccc75 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2017 Andy Wingo <wingo@pobox.com>
;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
@@ -209,12 +209,12 @@ other applications that need to directly deal with input devices.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autogen
+ (add-after 'unpack 'patch-autogen
(lambda _
;; Run 'configure' in its own phase, not now.
(substitute* "autogen.sh"
(("^.*\\./configure.*") ""))
- (zero? (system* "sh" "autogen.sh")))))))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)