summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-02 00:45:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-02 21:18:39 +0100
commit62a91d2e2302cc960d970064d066b5c603a91df3 (patch)
tree34ca81d82894de3f4c566f35287dde21d6abd925 /gnu/packages/freedesktop.scm
parent550f4509acf2c0f67882260414b0bb2843e07465 (diff)
downloadpatches-62a91d2e2302cc960d970064d066b5c603a91df3.tar
patches-62a91d2e2302cc960d970064d066b5c603a91df3.tar.gz
gnu: wayland: Update to 1.14.0.
* gnu/packages/freedesktop.scm (wayland): Update to 1.14.0. [arguments]<#:phases>: Remove.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 950961ee9f..af1ec1293f 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -393,28 +393,17 @@ Python.")
(define-public wayland
(package
(name "wayland")
- (version "1.13.0")
+ (version "1.14.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wayland.freedesktop.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0lgywr1m0d79vr4s8aimj8a307nss29hhy68gjpqj7m667055c39"))))
+ "1f3sla6h0bw15fz8pjc67jhwj7pwmfdc7qlj42j5k9v116ycm07d"))))
(build-system gnu-build-system)
(arguments
- `(#:parallel-tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Remove record shapes to workaround graphviz 2.40.1 problems.
- ;; http://www.graphviz.org/content/i-havent-been-able-render-these-files-graphviz-226
- ;; This will likely be fixed upstream in the next release.
- ;; https://lists.freedesktop.org/archives/wayland-devel/2017-June/034218.html
- (add-before 'build 'fix-graphviz
- (lambda _
- (substitute* "doc/doxygen/dot/x-architecture.gv"
- (("Mrecord") "none"))
- #t)))))
+ `(#:parallel-tests? #f))
(native-inputs
`(("doxygen" ,doxygen)
("graphviz" ,graphviz)