summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-21 14:31:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-21 14:31:36 +0100
commit8505eb19a4071f563811d4fe33471441c2db58b7 (patch)
tree123241c704e7d1a88eb4efe2793a6898e2e72216 /gnu/packages/freedesktop.scm
parent3b88f3767d9f3ad2cc64173525cd53d429bfe7e7 (diff)
parentb097a3387ea78797104f97eef445f5da6278c922 (diff)
downloadpatches-8505eb19a4071f563811d4fe33471441c2db58b7.tar
patches-8505eb19a4071f563811d4fe33471441c2db58b7.tar.gz
Merge branch 'staging' into core-updates
Conflicts: gnu/local.mk: Missing mention of gdk-pixbuf-list-dir.patch in the commit log really confused me here... It's from 8c6b077bfae (staging). gnu/packages/xorg.scm: xkeyboard-config updated both places.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f9007b1b36..6deb929458 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -274,14 +274,14 @@ Python.")
(define-public wayland
(package
(name "wayland")
- (version "1.11.0")
+ (version "1.12.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wayland.freedesktop.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1c0d5ivy9n44hykvw2ggrvqrnn7naw3wg11vbvgwzgi8g5gr4h4m"))))
+ "1c8sha5vm8w346wcbvgnjihisxfyvrr3qlbmfb5sp201p9f17d6n"))))
(build-system gnu-build-system)
(arguments `(#:parallel-tests? #f))
(native-inputs
@@ -331,7 +331,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public weston
(package
(name "weston")
- (version "1.11.0")
+ (version "1.12.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -339,7 +339,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
"weston-" version ".tar.xz"))
(sha256
(base32
- "09biddxw3ar797kxf9mywjkb2iwky6my39gpp51ni846y7lqdq05"))))
+ "0cshmw4ql4cr36v90bbi4qi6plvb6b9dbpnc3w9m17rv5siw4ymc"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -372,9 +372,11 @@ applications, X servers (rootless or fullscreen) or other display servers.")
;; Use elogind instead of systemd
(substitute* "configure"
(("libsystemd-login >= 198") "libelogind"))
- (substitute* '("src/launcher-logind.c" "src/weston-launch.c")
+ (substitute* '("libweston/launcher-logind.c"
+ "libweston/weston-launch.c")
(("#include <systemd/sd-login.h>")
- "#include <elogind/sd-login.h>"))))
+ "#include <elogind/sd-login.h>"))
+ #t))
(add-after 'configure 'patch-confdefs.h
(lambda _
(system "echo \"#define HAVE_SYSTEMD_LOGIN_209 1\" >> confdefs.h")))