summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-12-15 19:32:50 +0800
committer宋文武 <iyzsong@gmail.com>2015-12-20 18:59:21 +0800
commite68232797656813ceb139fa01d465290eed84a66 (patch)
tree9817d24ffb25106e9bd6579f8b143082b9dc58da /gnu/packages/freedesktop.scm
parent6976e7d2fff3833568c1a8f3def8d3c64214177f (diff)
downloadpatches-e68232797656813ceb139fa01d465290eed84a66.tar
patches-e68232797656813ceb139fa01d465290eed84a66.tar.gz
gnu: Add colord-gtk.
* gnu/packages/freedesktop.scm (colord-gtk): New variable.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 474cf24af0..b8eb75eddd 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages xml)
#:use-module (gnu packages docbook)
#:use-module (gnu packages glib) ;intltool
@@ -568,3 +569,33 @@ modems and setup connections with them.")
received by the Telepathy framework. It features pluggable backends to log
different sorts of messages in different formats.")
(license license:lgpl2.1+)))
+
+(define-public colord-gtk
+ (package
+ (name "colord-gtk")
+ (version "0.1.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.freedesktop.org/software/colord"
+ "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0i9y3bb5apj6a0f8cx36l6mjzs7xc0k7nf0magmf58vy2mzhpl18"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; require the colord system service
+ (native-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (propagated-inputs
+ ;; colord-gtk.pc refers to all these.
+ `(("colord" ,colord)
+ ("gtk+" ,gtk+)))
+ (synopsis "GTK integration for libcolord")
+ (home-page "http://www.freedesktop.org/software/colord/")
+ (description
+ "This is a GTK+ convenience library for interacting with colord. It is
+useful for both applications which need colour management and applications that
+wish to perform colour calibration.")
+ (license license:lgpl2.1+)))