summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-06-17 18:27:37 +0800
committer宋文武 <iyzsong@gmail.com>2015-06-17 18:29:15 +0800
commit6178d94706cb3000859bc3f84bdbf7e796375d55 (patch)
treefd6942ad5466689c4888ea23ad615d1ef4667175 /gnu/packages/freedesktop.scm
parentf5a9ffa006687c6759e3d329159dc938b4a705ea (diff)
downloadpatches-6178d94706cb3000859bc3f84bdbf7e796375d55.tar
patches-6178d94706cb3000859bc3f84bdbf7e796375d55.tar.gz
gnu: Add wayland.
* gnu/packages/freedesktop.scm (wayland): New variable.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c5b55f30a2..eeb97cdc85 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -38,7 +38,9 @@
#:use-module (gnu packages docbook)
#:use-module (gnu packages glib) ;intltool
#:use-module (gnu packages xdisorg)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages doxygen)
+ #:use-module (gnu packages libffi))
(define-public xdg-utils
(package
@@ -197,3 +199,36 @@ Python")
(define-public python2-pyxdg
(package-with-python2 python-pyxdg))
+
+(define-public wayland
+ (package
+ (name "wayland")
+ (version "1.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://wayland.freedesktop.org/releases/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1j3gfzn8i0xhk3j34mwb2srrscjxfyi279jhyq80mz943j6r6z7i"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)
+ ("xmlto" ,xmlto)
+ ("xsltproc" ,libxslt)))
+ (inputs
+ `(("docbook-xml" ,docbook-xml)
+ ("docbook-xsl" ,docbook-xsl)
+ ("expat" ,expat)
+ ("libffi" ,libffi)
+ ("libxml2" ,libxml2))) ; for XML_CATALOG_FILES
+ (home-page "http://wayland.freedesktop.org/")
+ (synopsis "Display server protocol")
+ (description
+ "Wayland is a protocol for a compositor to talk to its clients as well as
+a C library implementation of that protocol. The compositor can be a standalone
+display server running on Linux kernel modesetting and evdev input devices, an X
+application, or a wayland client itself. The clients can be traditional
+applications, X servers (rootless or fullscreen) or other display servers.")
+ (license license:x11)))