summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-14 13:02:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-14 13:06:02 +0200
commit7ca37da855fd921fa3925bb62f8015f770b7e784 (patch)
treee5584b6efe36ede6e8e0b310c2021f3b0be0c33a /gnu/packages/freedesktop.scm
parent73bb984ec4267a077f3e56f0cd730738c1a70aef (diff)
downloadpatches-7ca37da855fd921fa3925bb62f8015f770b7e784.tar
patches-7ca37da855fd921fa3925bb62f8015f770b7e784.tar.gz
gnu: libinput: Enable GUI event tool.
* gnu/packages/freedesktop.scm (libinput)[inputs]: Add glib. [native-inputs]: Add cairo, gtk+-3. (libinput-minimal)[native-inputs]: Only pkg-config.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f6b6dbeb8a..a55069d59f 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -95,11 +95,14 @@ freedesktop.org project.")
"1n1dispg63z1qiy8c1af3l9c4a9dks8y7xasff8xcywnn0rkkxnl"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("cairo" ,cairo)
+ ("gtk+" ,gtk+)
+ ("pkg-config" ,pkg-config)))
(propagated-inputs
`(("libudev" ,eudev))) ; required by libinput.pc
(inputs
- `(("libevdev" ,libevdev)
+ `(("glib" ,glib)
+ ("libevdev" ,libevdev)
("mtdev" ,mtdev)
("libwacom" ,libwacom)))
(home-page "https://www.freedesktop.org/wiki/Software/libinput/")
@@ -112,6 +115,8 @@ other applications that need to directly deal with input devices.")
(define-public libinput-minimal
(package (inherit libinput)
(name "libinput-minimal")
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("libevdev" ,libevdev)
("mtdev" ,mtdev)))