summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-04-03 10:27:45 +0300
committerAlex Kost <alezost@gmail.com>2016-04-03 10:37:44 +0300
commitf8835ff4b3dd59d59bf44838d05d3d60114d15d2 (patch)
treea16bdafd7201b3e8e4f3f713317ae23c6748a282 /gnu/packages/fontutils.scm
parentea5d388257664d703df23cf3eb0da7b6546d6c42 (diff)
downloadpatches-f8835ff4b3dd59d59bf44838d05d3d60114d15d2.tar
patches-f8835ff4b3dd59d59bf44838d05d3d60114d15d2.tar.gz
gnu: fontconfig: Find fonts in the system profile.
Fixes <http://bugs.gnu.org/22927>. Reported by myglc2 <myglc2@gmail.com>. This also reverts commit e71ef7adaece7e132a5059139122b45083ea1b39. * gnu/packages/fontutils.scm (fontconfig)[arguments]: Add /run/current-system/profile/share/fonts to --with-add-fonts configure flag. * gnu/system/shadow.scm (default-skeletons): Do not create "fonts.conf" file.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 7e3f293817..2912ce2366 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -95,10 +95,10 @@ anti-aliased glyph bitmap generation with 256 gray levels.")
(assoc-ref %build-inputs "gs-fonts")
"/share/fonts")
- ;; register fonts from user profile
- ;; TODO: Add /run/current-system/profile/share/fonts and remove
- ;; the skeleton that works around it from 'default-skeletons'.
- "--with-add-fonts=~/.guix-profile/share/fonts"
+ ;; Register fonts from user and system profiles.
+ (string-append "--with-add-fonts="
+ "~/.guix-profile/share/fonts,"
+ "/run/current-system/profile/share/fonts")
;; python is not actually needed
"PYTHON=false")