summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-22 11:33:35 +0800
committer宋文武 <iyzsong@gmail.com>2015-09-06 21:52:21 +0800
commite6f22a828e303a2f1af6547785016356eba99063 (patch)
tree935e8366e4b9ffb05b9ced9a754e4beac8b49ec8 /gnu/packages/fontutils.scm
parentd582eaacec4bd55e9edfd21ad69cd232a157cb31 (diff)
downloadpatches-e6f22a828e303a2f1af6547785016356eba99063.tar
patches-e6f22a828e303a2f1af6547785016356eba99063.tar.gz
gnu: graphite2: Update to 1.3.1.
* gnu/packages/fontutils.scm (graphite2): Update to 1.3.1. Remove unused PERL from inputs. [native-inputs]: New field.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index a25a2ea0e9..3db8f9f11d 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -203,7 +203,7 @@ applications should be.")
(define-public graphite2
(package
(name "graphite2")
- (version "1.2.4")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
@@ -212,12 +212,13 @@ applications should be.")
version ".tgz"))
(sha256
(base32
- "00xhv1mp640fr3wmdzwn4yz0g56jd4r9fb7b02mc1g19h0bdbhsb"))))
+ "0xvhmlyyxg2qmbwyl8k2f9w7mrbjyl59823pnjd8xmxpyl6976d5"))))
(build-system cmake-build-system)
+ (native-inputs
+ `(("python" ,python-2) ; because of "import imap" in tests
+ ("python-fonttools" ,python2-fonttools)))
(inputs
- `(("freetype" ,freetype)
- ("perl" ,perl)
- ("python" ,python-2))) ; because of "import imap" in tests
+ `(("freetype" ,freetype)))
(synopsis "Reimplementation of the SIL Graphite text processing engine")
(description
"Graphite2 is a reimplementation of the SIL Graphite text processing