summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-20 11:26:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-20 11:57:25 +0100
commit019c0eda941274f586aa1a2c8fa2b7aa9d6ec001 (patch)
tree1f54d421ff79e54a0a70ce3437d015498d037b74 /gnu/packages/fontutils.scm
parent7428581f8d2a7b637a912a9681e2360bffbfae59 (diff)
downloadpatches-019c0eda941274f586aa1a2c8fa2b7aa9d6ec001.tar
patches-019c0eda941274f586aa1a2c8fa2b7aa9d6ec001.tar.gz
gnu: fontconfig: Update to 2.13.0.
* gnu/packages/patches/fontconfig-remove-debug-printf.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/fontutils.scm (fontconfig): Update to 2.13.0. [source](patches): Remove. [propagated-inputs]: Add UTIL-LINUX.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index fb9f98dc9f..38065d530e 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages check)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages autotools)
@@ -231,18 +232,19 @@ fonts to/from the WOFF2 format.")
(define-public fontconfig
(package
(name "fontconfig")
- (version "2.12.6")
+ (version "2.13.0")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.freedesktop.org/software/fontconfig/release/fontconfig-"
version ".tar.bz2"))
- (patches (search-patches "fontconfig-remove-debug-printf.patch"))
(sha256 (base32
- "05zh65zni11kgnhg726gjbrd55swspdvhqbcnj5a5xh8gn03036g"))))
+ "1fgf28zgsqh7x6dw30n6zi9z679gx6dyfyahp55z7dsm454yipci"))))
(build-system gnu-build-system)
+ ;; In Requires or Requires.private of fontconfig.pc.
(propagated-inputs `(("expat" ,expat)
- ("freetype" ,freetype)))
+ ("freetype" ,freetype)
+ ("libuuid" ,util-linux)))
(inputs `(("gs-fonts" ,gs-fonts)))
(native-inputs
`(("gperf" ,gperf)