summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-03-31 00:36:22 -0500
committerEric Bavier <bavier@member.fsf.org>2016-04-15 00:23:28 -0500
commit1e69db8f1487ec61007099b3664e771094b8470b (patch)
treea6c74bede6f443131fa2a5f18a56d5856d3c2471 /gnu/packages/fontutils.scm
parent08fbfa8d21674738cf043bf4cc6fba1a91fc3162 (diff)
downloadpatches-1e69db8f1487ec61007099b3664e771094b8470b.tar
patches-1e69db8f1487ec61007099b3664e771094b8470b.tar.gz
gnu: Add ttfautohint.
* gnu/packages/fontutils.scm (ttfautohint): New variable. * gnu/packages/patches/ttfautohint-source-date-epoch.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index d64ed71bbf..c7cd519f65 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -29,6 +29,8 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages python)
#:use-module (gnu packages image)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages glib)
#:use-module (gnu packages xorg)
#:use-module (gnu packages gtk)
@@ -70,6 +72,37 @@ anti-aliased glyph bitmap generation with 256 gray levels.")
(license license:freetype) ; some files have other licenses
(home-page "http://www.freetype.org/")))
+(define-public ttfautohint
+ (package
+ (name "ttfautohint")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/freetype/ttfautohint-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1lgghck46p33z3hg8dnl76jryig4fh6d8rhzms837zp7x4hyfkv4"))
+ (patches (list (search-patch "ttfautohint-source-date-epoch.patch")))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("flex" ,flex)
+ ("bison" ,bison)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("harfbuzz" ,harfbuzz)))
+ (arguments
+ `(#:configure-flags '("--with-qt=no"))) ;no gui
+ (synopsis "Automated font hinting")
+ (description
+ "ttfautohint provides a 99% automated hinting process and a platform for
+finely hand-hinting the last 1%. It is ideal for web fonts and supports many
+scripts.")
+ (license (list license:gpl2+ license:freetype)) ;choose one or the other
+ (home-page "http://www.freetype.org/ttfautohint/")))
+
(define-public fontconfig
(package
(name "fontconfig")