summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorJens M <jens@zete.tk>2018-11-08 21:09:00 +1300
committerLeo Famulari <leo@famulari.name>2019-02-12 18:41:33 -0500
commit3cdd2e95e923c8df23ee5be604c4fd05a2db29f3 (patch)
treecc3ae147979ad5cccd3ea0d4c066c0225af4d142 /gnu/packages/fonts.scm
parent27e65afc10df2e6a7a20272b22a12404247f2585 (diff)
downloadpatches-3cdd2e95e923c8df23ee5be604c4fd05a2db29f3.tar
patches-3cdd2e95e923c8df23ee5be604c4fd05a2db29f3.tar.gz
gnu: Add font-adobe-source-serif-pro.
* gnu/packages/fonts.scm (font-adobe-source-serif-pro): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 7dae798438..9d49c02cf6 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -883,6 +883,31 @@ designed to work well in user interface environments.")
work well in user interface (UI) environments.")
(license license:silofl1.1)))
+(define-public font-adobe-source-serif-pro
+ (package
+ (name "font-adobe-source-serif-pro")
+ (version "2.007R-ro-1.007R-it")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/adobe-fonts/source-serif-pro/archive/"
+ (regexp-substitute/global
+ ;; The upstream tag uses "/" between the roman and italic
+ ;; versions, so substitute our "-" separator here.
+ #f "R-ro-" version 'pre "R-ro/" 'post) ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1sws9k26ldqk375qsigk1zv8cq1xlvadjwvv3dqrcc3qzm1c7hwc"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/adobe-fonts/source-serif-pro")
+ (synopsis
+ "Serif typeface to complement Source Sans Pro for setting text")
+ (description
+ "Source Serif Pro is a set of OpenType fonts to complement the Source
+Sans Pro family.")
+ (license license:silofl1.1)))
+
(define-public font-fira-mono
(package
(name "font-fira-mono")