summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2017-05-31 14:54:20 -0500
committerDanny Milosavljevic <dannym@scratchpost.org>2017-05-31 23:29:44 +0200
commitb6726480e2bee87b9ebc1d696f8b36465cd4321e (patch)
tree9ca4ca88b108962ba776751c550baa8104b21c2e /gnu/packages/fonts.scm
parent4a9140b1ee452c95682bb9e4e1b030f24f0c631d (diff)
downloadpatches-b6726480e2bee87b9ebc1d696f8b36465cd4321e.tar
patches-b6726480e2bee87b9ebc1d696f8b36465cd4321e.tar.gz
gnu: font-go: Use 'font-build-system'.
* gnu/packages/fonts.scm (font-go): Switch to font-build-system. Re-indent. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm54
1 files changed, 24 insertions, 30 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 6dc098a5e3..7a5e63629f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1226,39 +1226,33 @@ programming. Iosevka is completely generated from its source code.")
(let ((commit "f03a046406d4d7fbfd4ed29f554da8f6114049fc")
(revision "1"))
(package
- (name "font-go")
- (version (string-append "20170330-" revision "." (string-take commit 7)))
- (source (origin
- (file-name (string-append "go-image-" version "-checkout"))
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/image")
- (commit commit)))
- (sha256
- (base32
- "1aq6mnjayks55gd9ahavk6jfydlq5lm4xm0xk4pd5sqa74p5p74d"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder (begin
- (use-modules (guix build utils))
- (let ((font-dir (string-append %output
- "/share/fonts/truetype"))
- (source (assoc-ref %build-inputs "source")))
- (mkdir-p font-dir)
- (with-directory-excursion
- (string-append source "/font/gofont/ttfs")
- (for-each (lambda (ttf)
- (install-file ttf font-dir))
- (find-files "." "\\.ttf$")))))))
- (home-page "https://blog.golang.org/go-fonts")
- (synopsis "The Go font family")
- (description
- "The Go font family is a set of WGL4 TrueType fonts from the Bigelow &
+ (name "font-go")
+ (version (string-append "20170330-" revision "." (string-take commit 7)))
+ (source (origin
+ (file-name (string-append "go-image-" version "-checkout"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/image")
+ (commit commit)))
+ (sha256
+ (base32
+ "1aq6mnjayks55gd9ahavk6jfydlq5lm4xm0xk4pd5sqa74p5p74d"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'chdir
+ (lambda _
+ (chdir "font/gofont/ttfs")
+ #t)))))
+ (home-page "https://blog.golang.org/go-fonts")
+ (synopsis "The Go font family")
+ (description
+ "The Go font family is a set of WGL4 TrueType fonts from the Bigelow &
Holmes type foundry, released under the same license as the Go programming
language. It includes a set of proportional, sans-serif fonts, and a set of
monospace, slab-serif fonts.")
- (license (package-license go-1.4)))))
+ (license (package-license go-1.4)))))
(define-public font-google-material-design-icons
(package