summaryrefslogtreecommitdiff
path: root/gnu/packages/flex.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 15:34:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:23:36 +0200
commit34f4c214b63c46ee609bbaa15b063e20bc739ce3 (patch)
tree18bbdcf8e10cbe9b0438a0a4e13d818c5505a7a4 /gnu/packages/flex.scm
parent2fa4066c0a7c44ec5686a6197542e56c9e47fa45 (diff)
downloadpatches-34f4c214b63c46ee609bbaa15b063e20bc739ce3.tar
patches-34f4c214b63c46ee609bbaa15b063e20bc739ce3.tar.gz
gnu: flex: Update bison-for-tests to 3.0.5.
* gnu/packages/flex.scm (flex)[inputs]: Make BISON-FOR-TESTS inherit source from BISON, and disable tests on it since they require flex.
Diffstat (limited to 'gnu/packages/flex.scm')
-rw-r--r--gnu/packages/flex.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index 29c5c92766..e08b0c13db 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -45,22 +45,10 @@
(build-system gnu-build-system)
(inputs
(let ((bison-for-tests
- ;; Work around an incompatibility with Bison 3.0:
- ;; <http://lists.gnu.org/archive/html/bug-bison/2013-09/msg00014.html>.
(package
(inherit bison)
- (version "2.7.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://gnu/bison/"
- "bison-" version ".tar.xz"))
- (sha256
- (base32
- "1yx7isx67sdmyijvihgyra1f59fwdz7sqriginvavfj5yb5ss2dl"))))
-
- ;; Unlike Bison 3.0, this version did not need Flex for its
- ;; tests, so it allows us to break the cycle.
+ ;; Disable tests, since they require flex.
+ (arguments '(#:tests? #f))
(inputs (alist-delete "flex" (package-inputs bison))))))
`(("bison" ,bison-for-tests)
("indent" ,indent))))