summaryrefslogtreecommitdiff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-08 00:54:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-08 00:54:01 +0200
commitba00235a9652bb129ff6867ffc3c7cfafe1cca09 (patch)
tree1ce56f512707e89362e1fed3d5b26d690462fbda /gnu/packages/flashing-tools.scm
parentf19ccdc62ca721b68745c35b046826b356f46c62 (diff)
parent0e2b0b05accdea7c3f016f8483d0ec04021114d3 (diff)
downloadpatches-ba00235a9652bb129ff6867ffc3c7cfafe1cca09.tar
patches-ba00235a9652bb129ff6867ffc3c7cfafe1cca09.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 20e14417e4..d9c663d7f4 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -48,16 +48,15 @@
(define-public flashrom
(package
(name "flashrom")
- ;; XXX: The CFLAGS=... line below can probably be removed when updating.
- (version "1.0")
+ (version "1.0.1")
(source (origin
(method url-fetch)
(uri (string-append
- "https://download.flashrom.org/releases/flashrom-"
+ "https://download.flashrom.org/releases/flashrom-v"
version ".tar.bz2"))
(sha256
(base32
- "0r7fkpfc8w51n8ffbhclj4wa3kwrk0ijv1acwpw5myx5bchzl0ip"))))
+ "0i6yrrl69hrqmwd7azj7x3j46m0qpvzmk3b5basym7mnlpfzhyfm"))))
(build-system gnu-build-system)
(inputs `(("dmidecode" ,dmidecode)
("pciutils" ,pciutils)
@@ -67,9 +66,6 @@
(arguments
'(#:make-flags
(list "CC=gcc"
- ;; The default includes ‘-Wall -Werror’, causing the build to fail
- ;; with deprecation warnings against libusb versions >= 1.0.22.
- "CFLAGS=-Os -Wshadow"
(string-append "PREFIX=" %output)
"CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
#:tests? #f ; no 'check' target