summaryrefslogtreecommitdiff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-29 17:34:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-03-29 17:34:41 +0200
commit5576cfabf3485e0cf794cc3de085a3578151ee64 (patch)
tree8ca4093d05fda6b0064d0fca429353327ec491f9 /gnu/packages/flashing-tools.scm
parent12cb6c31df4b90d58658e88a256e36b6808e1064 (diff)
parente086d2f68b90a39bae07ae46572e5cc6b0fc4308 (diff)
downloadpatches-5576cfabf3485e0cf794cc3de085a3578151ee64.tar
patches-5576cfabf3485e0cf794cc3de085a3578151ee64.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 36c8353ee0..dd0eaa5df8 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -48,6 +48,7 @@
(define-public flashrom
(package
(name "flashrom")
+ ;; XXX: The CFLAGS=... line below can probably be removed when updating.
(version "1.0")
(source (origin
(method url-fetch)
@@ -64,9 +65,13 @@
("libftdi" ,libftdi)))
(native-inputs `(("pkg-config" ,pkg-config)))
(arguments
- '(#:make-flags (list "CC=gcc"
- (string-append "PREFIX=" %output)
- "CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
+ '(#:make-flags
+ (list "CC=gcc"
+ ;; The default includes ‘-Wall -Werror’, causing the build to fail
+ ;; with deprecation warnings against libusb versions >= 1.0.22.
+ "CFLAGS=-Os -Wshadow"
+ (string-append "PREFIX=" %output)
+ "CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
#:tests? #f ; no 'check' target
#:phases
(modify-phases %standard-phases