summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-12-28 22:28:13 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-28 22:28:13 +0100
commit50c4d676ff65a2e26a5df5745733b8cc16b23bc6 (patch)
tree4655be928958b3e12c2781bfc6648360c6342ec1 /gnu/packages/finance.scm
parentd6ddeffcbcf0ba1b82557da470004b050999762b (diff)
downloadpatches-50c4d676ff65a2e26a5df5745733b8cc16b23bc6.tar
patches-50c4d676ff65a2e26a5df5745733b8cc16b23bc6.tar.gz
gnu: Add keepkey-agent.
* gnu/packages/finance.scm (keepkey-agent): New variable.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 5284460bfe..c7843080e0 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -694,3 +694,24 @@ Then set the environment variable GNUPGHOME to
(description "This package allows using Trezor as a hardware SSH/GPG
agent.")
(license license:lgpl3)))
+
+(define-public keepkey-agent
+ (package
+ (name "keepkey-agent")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "keepkey_agent" version))
+ (sha256
+ (base32
+ "03779gvlx70i0nnry98i4pl1d92604ix5x6jgdfkrdgzqbh5vj27"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-keepkey" ,python-keepkey)
+ ("python-trezor-agent" ,python-trezor-agent)))
+ (home-page "http://github.com/romanz/trezor-agent")
+ (synopsis "KeepKey as hardware SSH/GPG agent")
+ (description "This package allows using KeepKey as a hardware SSH/GPG
+agent.")
+ (license license:lgpl3)))