summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-10-17 23:59:53 -0500
committerEric Bavier <bavier@member.fsf.org>2018-01-08 16:03:55 -0600
commit5424f9bcab01d7017550d79cdf42daea87151da0 (patch)
treed6309651875ede5fb4a79e3096d112d8f6b36637 /gnu/packages/finance.scm
parent7f9866a312f12b619df1baa83d889b82fb5874cf (diff)
downloadpatches-5424f9bcab01d7017550d79cdf42daea87151da0.tar
patches-5424f9bcab01d7017550d79cdf42daea87151da0.tar.gz
gnu: ledger: Fix test failures.
* gnu/packages/patches/ledger-revert-boost-python-fix.patch, gnu/packages/patches/ledger-fix-uninitialized.patch: New patches. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/finance.scm (ledger)[source]: Use them.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 402a61a631..2253a29fe3 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
+;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
+ #:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -130,7 +132,9 @@ line client and a client based on Qt.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "12jlv3gsjhrja25q9hrwh73cdacd2l3c2yyn8qnijav9mdhnbw4h"))))
+ "12jlv3gsjhrja25q9hrwh73cdacd2l3c2yyn8qnijav9mdhnbw4h"))
+ (patches (search-patches "ledger-revert-boost-python-fix.patch"
+ "ledger-fix-uninitialized.patch"))))
(build-system cmake-build-system)
(arguments
`(#:modules ((guix build cmake-build-system)