summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authormjbecze@riseup.net <mjbecze@riseup.net>2019-07-30 17:11:59 -0700
committerJulien Lepiller <julien@lepiller.eu>2019-08-01 22:04:22 +0200
commit01b37d0f74e483c1197f82b67b8575c0771bf08c (patch)
tree956375eab7e376668608251e5952b282cde291f3 /gnu/packages/finance.scm
parent0ca3ee43b762668ec4381429a53f5394c05db7d9 (diff)
downloadpatches-01b37d0f74e483c1197f82b67b8575c0771bf08c.tar
patches-01b37d0f74e483c1197f82b67b8575c0771bf08c.tar.gz
gnu: Add trezord.
* gnu/packages/finance.scm (trezord): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9b23013606..7a5efb76a9 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system go)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages base)
@@ -1086,3 +1088,26 @@ financial years, budget estimates, bankcard management and other
information.")
(home-page "http://grisbi.org")
(license license:gpl2+)))
+
+(define-public trezord
+ (package
+ (name "trezord")
+ (version "2.0.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/trezor/trezord-go.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0nqzpq0i3crh0i4r1cppja5sn3rwi1fv9afxzwzv63096x5l30a7"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/trezor/trezord-go"))
+ (home-page "https://trezor.io")
+ (synopsis "Trezor Communication Daemon aka Trezor Bridge (written in Go)")
+ (description "This allows a Trezor hardware wallet to communicate to the
+Trezor wallet.")
+ (license license:lgpl3+)))