aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-20 18:49:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-20 18:49:26 +0200
commit58366883f2f1516a4a02f5b4e2a70e86481827b5 (patch)
treefa67d714c4596164b341118132728a48135f4759 /gnu/packages/file.scm
parentf40aef6b3b56e1e5fb6e6ac29bd372000e13982f (diff)
parent9a1c4a981bdd7eeca76aaf73a57d6841918821c2 (diff)
downloadpatches-58366883f2f1516a4a02f5b4e2a70e86481827b5.tar
patches-58366883f2f1516a4a02f5b4e2a70e86481827b5.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 050e6715b1..3bc8e1dcfe 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,7 +27,8 @@
(define-public file
(package
- (name "file")
+ (replacement file/fixed)
+ (name "file")
(version "5.30")
(source (origin
(method url-fetch)
@@ -51,3 +52,9 @@ of the file.")
(license bsd-2)
(home-page "http://www.darwinsys.com/file/")))
+(define file/fixed
+ (package
+ (inherit file)
+ (source (origin
+ (inherit (package-source file))
+ (patches (search-patches "file-CVE-2017-1000249.patch"))))))