summaryrefslogtreecommitdiff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
commitd1f3b333e6176a7879ab3742bbebb2a99f61a528 (patch)
tree8bd82ce68bd2534a48bf13c7256997f82dd1b3f4 /gnu/packages/file.scm
parente01d384efcdaf564bbb221e43b81e087c8e2af06 (diff)
parent861907f01efb1cae7f260e8cb7b991d5034a486a (diff)
downloadpatches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar
patches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index d04357023d..9ba51d1b74 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -31,11 +31,11 @@
(package
(name "file")
(version "5.33")
- (replacement file/fixed)
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.astron.com/pub/file/file-"
version ".tar.gz"))
+ (patches (search-patches "file-CVE-2018-10360.patch"))
(sha256
(base32
"1iipnwjkag7q04zjkaqic41r9nlw0ml6mhqian6qkkbisb1whlhw"))))
@@ -55,10 +55,3 @@ extensions to tell you the type of a file, but looks at the actual contents
of the file. This package provides the libmagic library.")
(license bsd-2)
(home-page "https://www.darwinsys.com/file/")))
-
-(define file/fixed
- (package
- (inherit file)
- (source
- (origin (inherit (package-source file))
- (patches (search-patches "file-CVE-2018-10360.patch"))))))