summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-04 17:41:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-04 17:41:36 +0100
commita351fc83694f436c3bff7cbdef09bd3cc91c74fc (patch)
tree646145378742a6943d7c4dda995fc0fb67f9db32 /gnu/packages/enlightenment.scm
parent80b63e670ef4fe1fd40a903bcd4ee47a11415bd9 (diff)
parentd1a5b20081c30da7503201df260cf20b8d0ba633 (diff)
downloadpatches-a351fc83694f436c3bff7cbdef09bd3cc91c74fc.tar
patches-a351fc83694f436c3bff7cbdef09bd3cc91c74fc.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index ae0f553a36..6f081cf19b 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages game-development)
#:use-module (gnu packages gettext)
@@ -298,3 +299,33 @@ that tries to lower the barrier to getting involved in Enlightenment development
and in creating applications based on the Enlightenment Foundation Library suite.")
(license (list license:public-domain ; data/extra/skeleton
license:gpl2)))) ; edi
+
+(define-public lekha
+ (package
+ (name "lekha")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Lekha" version))
+ (sha256
+ (base32
+ "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no test target
+ #:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-data-location
+ (lambda _ (substitute* "setup.py"
+ (("'/usr/")"'"))
+ #t)))))
+ (propagated-inputs
+ `(("python2-efl" ,python2-efl)
+ ("python2-pypdf2" ,python2-pypdf2)
+ ("python2-pyxdg" ,python2-pyxdg)))
+ (synopsis "Simple PDF viewer")
+ (description
+ "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
+ (home-page "https://github.com/kaihu/lekha")
+ (license license:gpl3+)))