summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-05 13:13:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 15:25:27 +0300
commit35b380648b063db9a8b11352b1ae85d8f1ff7c70 (patch)
tree4aa6f6c19f969f118cb0f0025c08f7b937c40f7c /gnu/packages/enlightenment.scm
parent24262239da96eeabb0840c178ac6c80792e405c5 (diff)
downloadpatches-35b380648b063db9a8b11352b1ae85d8f1ff7c70.tar
patches-35b380648b063db9a8b11352b1ae85d8f1ff7c70.tar.gz
gnu: Remove elementary, evas-generic-loaders, emotion-generic-players.
* gnu/packages/enlightenment.scm (elementary, evas-generic-loaders) (emotion-generic-players): Remove variables. These packages were absorbed by efl-1.18.0.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm84
1 files changed, 0 insertions, 84 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index d465da9d71..7cd11b59a2 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -149,90 +149,6 @@ removable devices or support for multimedia.")
;; Different parts are under different licenses.
(license (list license:bsd-2 license:lgpl2.1 license:zlib))))
-(define-public elementary
- (package
- (name "elementary")
- (version "1.17.1")
- (source (origin
- (method url-fetch)
- (uri
- (string-append "https://download.enlightenment.org/rel/libs/"
- "elementary/elementary-" version ".tar.xz"))
- (sha256
- (base32
- "149xjq4z71l44w1kd8zks9b2g0wjc9656w46hzd27b58afj1dqc5"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (propagated-inputs
- `(("efl" ,efl))) ; elementary.pc, elementary-cxx.pc
- (home-page "https://www.enlightenment.org")
- (synopsis "Widget library of Enlightenment world")
- (description
- "Elementary is a widget library/toolkit, part of the Enlightenment
-Foundation Libraries. It is build upon Edje and Evas libraries and uses
-full capabilities of EFL.")
- (license license:lgpl2.1)))
-
-(define-public evas-generic-loaders
- (package
- (name "evas-generic-loaders")
- (version "1.17.0")
- (source (origin
- (method url-fetch)
- (uri
- (string-append
- "https://download.enlightenment.org/rel/libs/"
- "evas_generic_loaders/evas_generic_loaders-"
- version ".tar.xz"))
- (sha256
- (base32
- "0ynq1nx0bfgg19p4vki1fap36yyip53zaxpzncx2slr6jcx1kxf2"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("efl" ,efl)
- ("gstreamer" ,gstreamer)
- ("gst-plugins-base" ,gst-plugins-base)
- ("librsvg" ,librsvg)
- ("libspectre" ,libspectre)
- ("poppler" ,poppler)))
- (home-page "https://www.enlightenment.org")
- (synopsis "Plugins for integration of various file types into Evas")
- (description
- "Evas-generic-loaders is a collection of interfaces to outside libraries
-and applications allowing to natively open pictures, documents and media
-files in Evas (EFL canvas library).")
- (license license:gpl2+)))
-
-(define-public emotion-generic-players
- (package
- (name "emotion-generic-players")
- (version "1.17.0")
- (source (origin
- (method url-fetch)
- (uri
- (string-append "https://download.enlightenment.org/rel/libs/"
- "emotion_generic_players/emotion_generic_players"
- "-" version ".tar.xz"))
- (sha256
- (base32
- "03kaql95mk0c5j50v3c5i5lmlr3gz7xlh8p8q87xz8zf9j5h1pp7"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("efl" ,efl)
- ("vlc" ,vlc)))
- (home-page "https://www.enlightenment.org")
- (synopsis "Plugins for integrating media players in EFL based applications")
- (description
- "Emotion-generic-players is a collection of interfaces to outside libraries
-and applications allowing to natively play video files through Emotion.
-The only supported now is VLC.")
- (license license:bsd-2)))
-
(define-public terminology
(package
(name "terminology")