summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 14:29:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 15:17:47 +0100
commita8416e6951692d608574a4986bcbaf6def92e45c (patch)
tree5bf8eb2fcb3b08ab127baaa3651b4af84343cfa5 /gnu/packages/engineering.scm
parent5cb9754cf44598e6715ce6e984a97e6a589cf5f2 (diff)
downloadpatches-a8416e6951692d608574a4986bcbaf6def92e45c.tar
patches-a8416e6951692d608574a4986bcbaf6def92e45c.tar.gz
gnu: pcb-rnd: Use INVOKE.
* gnu/packages/engineering.scm (pcb-rnd)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 85e08289b5..9501e772fd 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
@@ -390,9 +390,9 @@ optimizer; and it can produce photorealistic and design review images.")
(replace 'configure
;; The configure script doesn't tolerate most of our configure flags.
(lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "sh" "configure"
- (string-append "--prefix="
- (assoc-ref outputs "out")))))))))
+ (invoke "sh" "configure"
+ (string-append "--prefix="
+ (assoc-ref outputs "out"))))))))
(home-page "http://repo.hu/projects/pcb-rnd/")
(description "PCB RND is a fork of the GNU PCB circuit board editing tool
featuring various improvements and bug fixes.")))