summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-07-03 00:14:55 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-07-04 02:45:39 +0200
commit6c08ea6a5cccc8685c347217ee6f5c567d8db1e7 (patch)
treede31548e751131d33c4082b1b3f450b05ef39b1f /gnu/packages/engineering.scm
parent7d0370ede4b46e2722ddf00ed11d99af226f4256 (diff)
downloadpatches-6c08ea6a5cccc8685c347217ee6f5c567d8db1e7.tar
patches-6c08ea6a5cccc8685c347217ee6f5c567d8db1e7.tar.gz
gnu: kicad-library: Return #t from phases.
* gnu/packages/engineering.scm (kicad-library)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8578789872..3bb49ff549 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -717,11 +717,11 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(modify-phases %standard-phases
(add-after 'install 'install-footprints ; from footprints tarball
(lambda* (#:key inputs outputs #:allow-other-keys)
- (zero? (system* "tar" "xvf"
- (assoc-ref inputs "kicad-footprints")
- "-C" (string-append (assoc-ref outputs "out")
- "/share/kicad/modules")
- "--strip-components=1"))))
+ (invoke "tar" "xvf"
+ (assoc-ref inputs "kicad-footprints")
+ "-C" (string-append (assoc-ref outputs "out")
+ "/share/kicad/modules")
+ "--strip-components=1")))
;; We change the default global footprint file, which is generated if
;; it doesn't exist in user's home directory, from the one using the
;; github plugin, to the one using the KISYSMOD environment path.