summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-15 19:26:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-15 19:26:55 +0200
commitbd21acf6c390e4fe87eb6053f0b5185d6ecbcf9f (patch)
tree09fe91a8351471e5e7a821cb28521dd9b9d7e357 /gnu/packages/engineering.scm
parenta4f1a7e2db22cd028fb514846c2791928b8734d3 (diff)
parentb44e19acd1a0d449427cea0333f02ac98605be1c (diff)
downloadpatches-bd21acf6c390e4fe87eb6053f0b5185d6ecbcf9f.tar
patches-bd21acf6c390e4fe87eb6053f0b5185d6ecbcf9f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm32
1 files changed, 26 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6a5f12db6d..15101e3aee 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1018,22 +1018,42 @@ the 'showing the effect of'-style of operation.")
(define-public volk
(package
(name "volk")
- (version "1.3")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
- (uri (string-append "http://libvolk.org/releases/volk-"
+ (uri (string-append "https://www.libvolk.org/releases/volk-"
version ".tar.gz"))
(sha256
(base32
- "1bz3ywc6y5wmz3i8p4z2wbzhns8bc0ywdkl9qnxpcvfcscarbdlh"))))
+ "1wz5nhmw6np8ka30pgy1qnima3rk2ksln4klfhrj7wah3fian0k9"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-pythonpath
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (python (assoc-ref inputs "python"))
+ (file (string-append out "/bin/volk_modtool"))
+ (path (string-append
+ out
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages:"
+ (getenv "PYTHONPATH"))))
+ (wrap-program file
+ `("PYTHONPATH" ":" prefix (,path))
+ `("PATH" ":" prefix
+ (,(string-append python "/bin:")))))
+ #t)))))
(inputs
`(("boost" ,boost)))
(native-inputs
- `(("python-2" ,python-2)
- ("python2-cheetah" ,python2-cheetah)))
- (home-page "http://libvolk.org/")
+ `(("python" ,python-wrapper)
+ ("python-mako" ,python-mako)))
+ (home-page "https://www.libvolk.org/")
(synopsis "Vector-Optimized Library of Kernels")
(description
"@code{volk} contains procedures with machine-specific optimizations