summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 15:20:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 15:20:25 +0100
commit02d38bd3a2c964698ef08524d6313b726ce63846 (patch)
tree94a0e57b2e017ba80a9f7309aae241862ea2e81f /gnu/packages/embedded.scm
parent2b965485e2f3a8755efff58fc1abad75df3e37a0 (diff)
parent776248419fe521afe9c6dd4b2fac6fc4b8b18e9b (diff)
downloadpatches-02d38bd3a2c964698ef08524d6313b726ce63846.tar
patches-02d38bd3a2c964698ef08524d6313b726ce63846.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index f20d1e17c7..1e7fd098cb 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -348,8 +348,8 @@ SEGGER J-Link and compatible devices.")
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out))))))))
(home-page "http://jim.tcl.tk")
(synopsis "Small footprint Tcl implementation")
(description "Jim is a small footprint implementation of the Tcl programming
@@ -575,7 +575,7 @@ with a layered architecture of JTAG interface and TAP support.")
;; have to create the target directories at build time.
(add-before 'build 'create-target-directories
(lambda* (#:key make-flags #:allow-other-keys)
- (zero? (apply system* "make" "install-dirs" make-flags))))
+ (apply invoke "make" "install-dirs" make-flags)))
(add-before 'build 'set-cross-environment-variables
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CROSS_LIBRARY_PATH"
@@ -589,7 +589,7 @@ with a layered architecture of JTAG interface and TAP support.")
#t))
(add-before 'install 'install-includes
(lambda* (#:key make-flags #:allow-other-keys)
- (zero? (apply system* "make" "install-includes" make-flags)))))))
+ (apply invoke "make" "install-includes" make-flags))))))
(native-inputs
`(("propeller-gcc" ,propeller-gcc)
("propeller-binutils" ,propeller-binutils)