summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-12-25 21:56:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-01 13:56:28 +0100
commitc6b96af794feece3ca29d12b1d9dadc2f7584df2 (patch)
tree6b45b79515b267d111cc1061dbedb04b8ad543e5 /gnu/packages/embedded.scm
parent150e0a1ec60350fa4af9aa7e060ffc77e2f8e3b5 (diff)
downloadpatches-c6b96af794feece3ca29d12b1d9dadc2f7584df2.tar
patches-c6b96af794feece3ca29d12b1d9dadc2f7584df2.tar.gz
gnu: Add propeller-load.
* gnu/packages/embedded.scm (propeller-load): New variable.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index f671552c89..e8f8cc858e 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -581,3 +581,36 @@ Parallax Propeller. It was ported from Chip Gracey's original x86 assembler
code.")
(license license:expat)))
+(define-public propeller-load
+ (let ((commit "ba9c0a7251cf751d8d292ae19ffa03132097c0c0")
+ (revision "1"))
+ (package
+ (name "propeller-load")
+ (version "3.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dbetz/propeller-load.git")
+ (commit commit)))
+ (file-name (string-append name "-" commit "-checkout"))
+ (sha256
+ (base32
+ "1qv3xaapl9fmj3zn58b60sprp4rnvnlpci8ci0pdrzkw6fhvx3pg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list "OS=linux"
+ (string-append "TARGET=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("openspin" ,openspin)
+ ("propeller-toolchain" ,propeller-toolchain)))
+ (home-page "https://github.com/dbetz/propeller-load")
+ (synopsis "Loader for Parallax Propeller micro-controllers")
+ (description "This package provides the tool @code{propeller-load} to
+upload binaries to a Parallax Propeller micro-controller.")
+ (license license:expat))))
+