summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorJames Richardson <james@jamestechnotes.com>2017-05-24 01:26:44 -0400
committerLudovic Courtès <ludo@gnu.org>2017-05-28 23:13:39 +0200
commitce676015645949091ceb54f7eb9daede7bc619fc (patch)
tree535e6a7ed63dcb180e5a49065517b2b42856ab47 /gnu/packages/emacs.scm
parent8902d0f2676a500c785044fff54b8675f96cef6d (diff)
downloadpatches-ce676015645949091ceb54f7eb9daede7bc619fc.tar
patches-ce676015645949091ceb54f7eb9daede7bc619fc.tar.gz
gnu: Add emacs-restclient.
* gnu/packages/emacs.scm (emacs-restclient): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 13eba9646e..db4695f236 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4880,3 +4880,31 @@ running tests easier.")
pair of minor modes which suppress all mouse events by intercepting them and
running a customisable handler command (@code{ignore} by default). ")
(license license:gpl3+)))
+
+(define-public emacs-restclient
+ (let ((commit "07a3888bb36d0e29608142ebe743b4362b800f40")
+ (revision "1")) ;Guix package revision,
+ ;upstream doesn't have official releases
+ (package
+ (name "emacs-restclient")
+ (version (string-append revision "."
+ (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pashky/restclient.el.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "00lmjhb5im1kgrp54yipf1h9pshxzgjlg71yf2rq5n973gvb0w0q"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/pashky/restclient.el")
+ (synopsis "Explore and test HTTP REST webservices")
+ (description
+ "This tool allows for testing and exploration of HTTP REST Web services
+from within Emacs. Restclient runs queries from a plan-text query sheet,
+displays results pretty-printed in XML or JSON with @code{restclient-mode}")
+ (license license:public-domain))))