summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-05-11 23:23:30 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-05-13 20:44:58 +0530
commit99d406c92d075219f8a53c59a9f1a10f1f6aaaa0 (patch)
tree1d1153416e13a9ef5ef29708bc6426ff30da013b /gnu/packages/emacs.scm
parent1812205cf56011293cdd3c8d522e4154c8e617dd (diff)
downloadpatches-99d406c92d075219f8a53c59a9f1a10f1f6aaaa0.tar
patches-99d406c92d075219f8a53c59a9f1a10f1f6aaaa0.tar.gz
gnu: Add emacs-ansi.
* gnu/packages/emacs.scm (emacs-ansi): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8f966d0576..ccd70db41e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4642,3 +4642,30 @@ addition of surrounding pairs, such as parantheses and quotes, in evil mode.")
comment out lines of code in evil mode. It provides @code{gcc} to comment out
lines, and @code{gc} to comment out the target of a motion.")
(license license:gpl3+)))
+
+;; Tests for emacs-ansi have a circular dependency with ert-runner, and
+;; therefore cannot be run
+(define-public emacs-ansi
+ (package
+ (name "emacs-ansi")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rejeep/ansi.el/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "13jj4vbi98j3p17hs99bmy7g21jd5h4v3wpxk4pkvhylm3bfwjw8"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/rejeep/ansi.el")
+ (synopsis "Convert strings to ANSI")
+ (description "@code{emacs-ansi} defines functions that turns simple
+strings to ANSI strings. Turning a string into an ANSI string can be to add
+color to a text, add color in the background of a text or adding a style, such
+as bold, underscore or italic.")
+ (license license:gpl3+)))