summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-02 17:03:32 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-13 23:30:15 +0100
commitcc353cc067904f9d9c57b053a84ce62c6981436b (patch)
tree74ddbf5756cde7f50a376e81d72aa9b5a0314154 /gnu/packages/emacs.scm
parent5144df2c6cd7b7044932311133b49fb84e78e794 (diff)
downloadpatches-cc353cc067904f9d9c57b053a84ce62c6981436b.tar
patches-cc353cc067904f9d9c57b053a84ce62c6981436b.tar.gz
gnu: Add emacs-tldr.
* gnu/packages/emacs.scm (emacs-tldr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 885bb7d5d2..9942779e07 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12933,3 +12933,25 @@ defining multiple keys in multiple keymaps at once, implicitly wrapping key
strings with (@code{kbd ...}), using named prefix key sequences (like the
leader key in vim), and much more.")
(license license:gpl3+))))
+
+(define-public emacs-tldr
+ (let ((commit "398b197c8d2238628b07e1b32d0f373876279f4c"))
+ (package
+ (name "emacs-tldr")
+ (version (git-version "0" "0" commit))
+ (home-page "https://github.com/kuanyui/tldr.el")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit commit)))
+ (sha256
+ (base32
+ "0iq7qlis6c6r2qkdpncrhh5vsihkhvy5x4y1y8cjb7zxkh62w33f"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (synopsis "Simplified and community-driven man pages for Emacs")
+ (description "@code{emacs-tldr} allows the user to access tldr pages
+from within emacs. The @code{tldr} pages are a community effort to simplify
+the man pages with practical examples.")
+ (license license:wtfpl2))))