summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-07-22 18:57:03 -0400
committerLudovic Courtès <ludo@gnu.org>2017-08-01 15:33:07 +0200
commit4bfdf034e24853ddea52d2aafd00036981bd187f (patch)
tree07b7eecbe8d39faaca426ce00471943627a1f529 /gnu/packages/emacs.scm
parent1f0d47059d31bbbaf588a4ca2de38d2ded8678cc (diff)
downloadpatches-4bfdf034e24853ddea52d2aafd00036981bd187f.tar
patches-4bfdf034e24853ddea52d2aafd00036981bd187f.tar.gz
gnu: Add emacs-yasnippet-snippets.
* gnu/packages/emacs.scm (emacs-yasnippet-snippets): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f6411c78c7..917c511f32 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4140,6 +4140,51 @@ mode-line.")
abbreviation and automatically expand it into function templates.")
(license license:gpl3+)))
+(define-public emacs-yasnippet-snippets
+ (let ((commit "885050d34737e2fb36a3e7759d60c09347bd4ce0")
+ (revision "1"))
+ (package
+ (name "emacs-yasnippet-snippets")
+ (version (string-append "1-" revision "." (string-take commit 8)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AndreaCrotti/yasnippet-snippets")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1m935zgglw0iakzrixld5rcjz3wnj84f8wy2mvc3pggjri9l0qr9"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((ice-9 ftw)
+ (ice-9 regex)
+ (guix build utils))
+ #:builder
+ (begin
+ (use-modules (ice-9 ftw)
+ (ice-9 regex)
+ (guix build utils))
+ (with-directory-excursion (assoc-ref %build-inputs "source")
+ (for-each (lambda (dir)
+ (copy-recursively
+ dir
+ (string-append %output
+ "/share/emacs/yasnippet-snippets/"
+ dir)))
+ (scandir "." (lambda (fname)
+ (and (string-match "-mode$" fname)
+ (directory-exists? fname)))))))))
+ (home-page "https://github.com/AndreaCrotti/yasnippet-snippets")
+ (synopsis "Collection of YASnippet snippets for many languages")
+ (description
+ "Provides Andrea Crotti's collection of YASnippet snippets. After installation,
+the snippets will be in \"~/.guix-profile/share/emacs/yasnippet-snippets/\".
+To make YASnippet aware of these snippets, add the above directory to
+@code{yas-snippet-dirs}.")
+ (license license:expat))))
+
(define-public emacs-memoize
(package
(name "emacs-memoize")