summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 01:12:50 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:12 +0200
commitf446f789e6936ac83a2c673dc79c8b8151d2abd2 (patch)
treec10f9fd4e4c68153e71bca02895ecc0fb28f841a /gnu/packages/emacs-xyz.scm
parentbbc22b984dfcaa054c64399a82cd6876cad13fd8 (diff)
downloadpatches-f446f789e6936ac83a2c673dc79c8b8151d2abd2.tar
patches-f446f789e6936ac83a2c673dc79c8b8151d2abd2.tar.gz
gnu: Add emacs-eacl.
* gnu/packages/emacs-xyz.scm (emacs-eacl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f6d9944a17..a1db2be856 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15078,6 +15078,29 @@ well as an option for visually flashing evaluated s-expressions.")
SSH servers.")
(license license:gpl3+)))
+(define-public emacs-eacl
+ (package
+ (name "emacs-eacl")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/redguardtoo/eacl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ksn11sm3g1ja5lpjz3hrzzw8b480mfcb3q589m52qjgvvn5iyfv"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ivy" ,emacs-ivy)))
+ (home-page "https://github.com/redguardtoo/eacl")
+ (synopsis "Auto-complete lines by using @code{grep} on a project")
+ (description "This package provides auto-completion cammands for single
+and multiple lines of code in a project.")
+ (license license:gpl3+)))
+
(define-public emacs-semantic-refactor
;; The last release, 0.5, was made on 2015-07-26 and there have been 47
;; commits since then.