summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 01:09:40 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:10 +0200
commit877546b46cec4d50aae22fdc255898e18c8088e4 (patch)
treeb5cc9907191752bb50182d543397007b11a945f9 /gnu/packages/emacs-xyz.scm
parent6746bdddf174209b657530b7154b77ce3ebbc2c8 (diff)
downloadpatches-877546b46cec4d50aae22fdc255898e18c8088e4.tar
patches-877546b46cec4d50aae22fdc255898e18c8088e4.tar.gz
gnu: Add emacs-prodigy-el.
* gnu/packages/emacs-xyz.scm (emacs-prodigy-el): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fa0b30b51a..280b9cda05 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14682,6 +14682,36 @@ invoked.")
(description "This package allows ERT to work with asynchronous tests.")
(license license:gpl3+)))
+(define-public emacs-prodigy-el
+ (let ((commit "701dccaa56de9e6a330c05bde33bce4f3b3d6a97")
+ (version "0.7.0")
+ (revision "28"))
+ (package
+ (name "emacs-prodigy-el")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rejeep/prodigy.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vyvxawlayp2nra0q83146q2nzv8qwn5a4nj0sx1jc90a0a83vgj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-s" ,emacs-s)
+ ("emacs-f" ,emacs-f)))
+ (native-inputs
+ `(("emacs-el-mock" ,emacs-el-mock)
+ ("emacs-ert-async" ,emacs-ert-async)))
+ (home-page "https://github.com/rejeep/prodigy.el")
+ (synopsis "Manage external services from within Emacs")
+ (description "This package provides a GUI for defining and monitoring services.")
+ (license license:gpl3+))))
+
(define-public emacs-semantic-refactor
;; The last release, 0.5, was made on 2015-07-26 and there have been 47
;; commits since then.