summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 01:11:19 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:10 +0200
commitfa07cf621ebb1673adb6fa17b52e4badfebc911d (patch)
treec6e5b7c14704b08581fda1b7ba4b5a47d7b029b1 /gnu/packages/emacs-xyz.scm
parentfba587b1adeeec004cc62402e56799bbe16eec48 (diff)
downloadpatches-fa07cf621ebb1673adb6fa17b52e4badfebc911d.tar
patches-fa07cf621ebb1673adb6fa17b52e4badfebc911d.tar.gz
gnu: Add emacs-flow-minor-mode.
* gnu/packages/emacs-xyz.scm (emacs-flow-minor-mode): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f56dfd7eac..1c3d0bbb23 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14808,6 +14808,30 @@ current file for the project's @file{node_modules/.bin/} directory, allowing
Emacs to find project-specific installations of packages.")
(license license:expat))))
+(define-public emacs-flow-minor-mode
+ (let ((commit "d1b32a7dd0d33c6a00a106da5f4b2323602cbd3e")
+ (version "0.3")
+ (revision "4"))
+ (package
+ (name "emacs-flow-minor-mode")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/an-sh/flow-minor-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "169r4ib9qg9q6fm3p0p23qs1qx4pa9pg1qvyq4ysr85i7kwygppl"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/an-sh/flow-minor-mode")
+ (synopsis "Minor mode for JavaScript Flow files")
+ (description "This package integrates Flow with Emacs, allowing for
+definition-jumping and type-checking on demand.")
+ (license license:bsd-3))))
+
(define-public emacs-semantic-refactor
;; The last release, 0.5, was made on 2015-07-26 and there have been 47
;; commits since then.