summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-14 10:02:17 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-14 18:00:32 +0200
commitde36efc2e0e35e1b6906469d0bab7210c0118c8e (patch)
tree5d962f2e49fc0eec308b8f4c0995df70b917cf87 /gnu/packages/emacs-xyz.scm
parentb0cf64c0bc493164515b5a09724c2dd3d3abf511 (diff)
downloadpatches-de36efc2e0e35e1b6906469d0bab7210c0118c8e.tar
patches-de36efc2e0e35e1b6906469d0bab7210c0118c8e.tar.gz
gnu: Add emacs-sly-macrostep.
* gnu/packages/emacs-xyz.scm (emacs-sly-macrostep): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed3d2d43e8..8db581d8af 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7106,6 +7106,39 @@ enables different readtables to be active in different parts of the same
file.")
(license license:gpl3+))))
+(define-public emacs-sly-macrostep
+ (let ((commit "be2d24545092d164be1a91031d8881afd29c9ec0")
+ (revision "1"))
+ (package
+ (name "emacs-sly-macrostep")
+ (version (git-version "0.1" revision commit))
+ (home-page "https://github.com/joaotavora/sly-macrostep")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v8m3zkccpqd2l8m9340y672l2mm3mrry8422nva5kfvpcwdayqb"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-sly" ,emacs-sly)
+ ("emacs-macrostep" ,emacs-macrostep)))
+ (arguments
+ '(#:include (cons* "\\.lisp$" "\\.asd$" %default-include)
+ #:phases
+ ;; The package provides autoloads.
+ (modify-phases %standard-phases
+ (delete 'make-autoloads))))
+ (synopsis "Expand Common Lisp macros inside source files with SLY")
+ (description
+ "@command{sly-macrostep} is a SLY contrib for expanding CL macros right
+inside the source file.")
+ (license license:gpl3+))))
+
(define-public emacs-lua-mode
(let ((commit "95c64bb5634035630e8c59d10d4a1d1003265743")
(revision "2"))