summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-02-20 16:12:58 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-02-20 16:12:58 +0100
commitf81efdcbdb6cff0bd54b680df4c9e33f0df667e8 (patch)
tree16668b0b41bcacefa529db382047e03deacaa95b /gnu/packages/emacs-xyz.scm
parente77c7210f002c27a6a05c65cbf4a918dbceaf237 (diff)
downloadpatches-f81efdcbdb6cff0bd54b680df4c9e33f0df667e8.tar
patches-f81efdcbdb6cff0bd54b680df4c9e33f0df667e8.tar.gz
gnu: emacs-helm-slime: Update to 0.2.0.
* gnu/packages/emacs-xyz.scm (emacs-helm-slime): Update to 0.2.0.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3afbcd6a95..63e34d9921 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12484,26 +12484,25 @@ correctly.")
(license license:gpl2+))))
(define-public emacs-helm-slime
- (let ((commit "bc4af154f2c18c8d9af968840f599d4c9974b668"))
- (package
- (name "emacs-helm-slime")
- (version (git-version "0.0.1" "1" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacs-helm/helm-slime")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0abfbzw1yaj9gscdxvvd3nf4h6krg6kyl5gpwgiyrq39x16pa9q2"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-helm" ,emacs-helm)
- ("emacs-slime" ,emacs-slime)))
- (home-page "https://github.com/emacs-helm/helm-slime")
- (synopsis "Helm for SLIME, the Superior Lisp Interaction Mode for Emacs")
- (description "Helm-SLIME defines a few new commands:
+ (package
+ (name "emacs-helm-slime")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-slime")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vn93vv2wclnwq6f480z14jn9wfp0ylhp5dd48ycc9jicfsnxqfj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-slime" ,emacs-slime)))
+ (home-page "https://github.com/emacs-helm/helm-slime")
+ (synopsis "Helm for SLIME, the Superior Lisp Interaction Mode for Emacs")
+ (description "Helm-SLIME defines a few new commands:
@itemize
@item helm-slime-complete: Select a symbol from the SLIME completion systems.
@@ -12511,7 +12510,7 @@ correctly.")
@item: helm-slime-apropos: Yet another slime-apropos with Helm.
@item helm-slime-repl-history: Select an input from the SLIME REPL history and insert it.
@end itemize\n")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-gtk-look
(package