summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorLaFreniere, Joseph <joseph@lafreniere.xyz>2020-02-22 17:08:51 -0600
committerEfraim Flashner <efraim@flashner.co.il>2020-02-23 11:41:14 +0200
commit5ce67a1c202d3cddf5d3b98a72eea78e02d4a681 (patch)
tree0d557bf0056b5ae09acb412529bc4eb114301feb /gnu/packages/emacs-xyz.scm
parent6634b29f501764f542e3a5fc91bb691ef18b5702 (diff)
downloadpatches-5ce67a1c202d3cddf5d3b98a72eea78e02d4a681.tar
patches-5ce67a1c202d3cddf5d3b98a72eea78e02d4a681.tar.gz
gnu: Add emacs-rg.
* gnu/packages/emacs-xyz.scm (emacs-rg): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1247c01e63..16e5a32574 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -135,6 +135,7 @@
#:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
#:use-module (gnu packages pdf)
+ #:use-module (gnu packages rust-apps)
#:use-module (gnu packages scheme)
#:use-module (gnu packages speech)
#:use-module (gnu packages xiph)
@@ -2779,6 +2780,43 @@ column by drawing a thin line down the length of the editing window.")
"This Emacs package allows managing multiple grep buffers.")
(license license:gpl3+)))
+(define-public emacs-rg
+ (package
+ (name "emacs-rg")
+ (version "1.8.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dajva/rg.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k7x5z7mh9flwih35cqy8chs54rack3nswdcpw5wcpgv6xim227y"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'hardcode-rg-path
+ ;; Hardcode the path to ripgrep.
+ (lambda _
+ (let ((file "rg.el"))
+ (chmod file #o644)
+ (emacs-substitute-sexps file
+ ("(defcustom rg-executable" (which "rg")))))))))
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)
+ ("emacs-wgrep" ,emacs-wgrep)))
+ (inputs
+ `(("ripgrep" ,ripgrep)))
+ (home-page "https://rgel.readthedocs.io/en/latest/")
+ (synopsis "Search tool based on @code{ripgrep}")
+ (description
+ "@code{rg} is an Emacs search package based on the @code{ripgrep} command
+line tool. It allows one to interactively search based on the editing context
+then refine or modify the search results.")
+ (license license:gpl3+)))
+
(define-public emacs-inf-ruby
(package
(name "emacs-inf-ruby")